aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2017-07-11 13:31:30 +0200
committerwsnipex <wsnipex@a1.net>2017-07-11 14:38:02 +0200
commitf0aa60a61c132b84e2268b37ea10de5ae16bb44b (patch)
treef69a3a99a087cd13e11c7d36990e301462856ff1 /CMakeLists.txt
parentb43d766dd864cc27d8eedcf340b59ab6a1a9e68b (diff)
[cmake] use lower case CORE_PLATFORM_NAME in conditionals
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bfe4091085..ede95f16ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,6 +103,10 @@ else()
endif()
set(CORE_PLATFORM_NAME ${_DEFAULT_PLATFORM} CACHE STRING "Platform port to build")
+#
+# Note: please do not use CORE_PLATFORM_NAME in any checks,
+# use the normalized to lower case CORE_PLATFORM_NAME_LC (see below) instead
+#
unset(_DEFAULT_PLATFORM)
string(TOLOWER ${CORE_PLATFORM_NAME} CORE_PLATFORM_NAME_LC)