aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2016-12-19 14:51:51 +0100
committerwsnipex <wsnipex@a1.net>2016-12-22 11:09:20 +0100
commit90a320bd96c1180ef649c66c1e0ecad1bf47d817 (patch)
treedd5b4c6c6884ca65a9fdc9f37e7a1d766f671337 /CMakeLists.txt
parent84c0737106c67fc38e817b177a3549b3f58665d9 (diff)
[cmake] libcec and ccache are optional deps
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1ceff5fbe..4e2009ceec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,7 +42,6 @@ option(ENABLE_DVDCSS "Enable libdvdcss support?" ON)
option(ENABLE_UPNP "Enable UPnP support?" ON)
option(ENABLE_NONFREE "Enable non-free components?" ON)
option(ENABLE_AIRTUNES "Enable AirTunes support?" ON)
-option(ENABLE_CEC "Enable CEC support?" ON)
option(ENABLE_OPTICAL "Enable optical support?" ON)
# use ffmpeg from depends or system
option(ENABLE_INTERNAL_FFMPEG "Enable internal ffmpeg?" OFF)
@@ -61,7 +60,6 @@ endif()
if(NOT WIN32)
option(WITH_ARCH "build with given arch" OFF)
option(WITH_CPU "build with given cpu" OFF)
- option(ENABLE_CCACHE "Enable Ccache support" ON)
endif()
if(CORE_SYSTEM_NAME STREQUAL linux OR CORE_SYSTEM_NAME STREQUAL rbpi)
option(ENABLE_LIRC "Enable LIRC support?" ON)
@@ -116,7 +114,7 @@ endif()
# Optional dependencies
set(optional_deps MicroHttpd MySqlClient SSH XSLT
- Alsa UDEV DBus Avahi SmbClient
+ Alsa UDEV DBus Avahi SmbClient CCache
PulseAudio VDPAU VAAPI Bluetooth CAP)
# Required, dyloaded deps
@@ -226,9 +224,6 @@ elseif(CORE_SYSTEM_NAME STREQUAL rbpi)
core_require_dep(MMAL)
endif()
-if(ENABLE_CCACHE)
- core_optional_dep(CCache)
-endif()
# Compile Info
add_custom_command(OUTPUT ${CORE_BUILD_DIR}/xbmc/CompileInfo.cpp