aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPär Björklund <per.bjorklund@gmail.com>2017-05-20 13:58:05 +0200
committerPÃr BjÃrklund <per.bjorklund@gmail.com>2017-05-20 14:00:54 +0200
commit4e6328b6425421376e8f03241deab7c7a9e9481e (patch)
tree1aa208182cf14ae9003f27ee65c04972ed9b2131 /CMakeLists.txt
parent0b6635408cb397281ce9919e968eb61f9e1d9aaf (diff)
Use PCH as intended to speed up build.
PCH was being built in a separate library to work around the lack of includes in certain parts of other libraries. This only complicated the build and wasn't really the intended use of a pch which is to speed up the build process.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 500b2adc06..5beacf7a8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -344,7 +344,7 @@ target_link_libraries(lib${APP_NAME_LC} PUBLIC ${core_DEPENDS} ${SYSTEM_LDFLAGS}
set_target_properties(lib${APP_NAME_LC} PROPERTIES PROJECT_LABEL "xbmc")
source_group_by_folder(lib${APP_NAME_LC} RELATIVE ${CMAKE_SOURCE_DIR}/xbmc)
if(WIN32)
- add_precompiled_header(lib${APP_NAME_LC} pch.h ${CMAKE_SOURCE_DIR}/xbmc/platform/win32/pch.cpp PCH_TARGET kodi)
+ add_precompiled_header(lib${APP_NAME_LC} pch.h ${CMAKE_SOURCE_DIR}/xbmc/platform/win32/pch.cpp)
set_language_cxx(lib${APP_NAME_LC})
endif()
@@ -381,9 +381,6 @@ whole_archive(_TEST_LIBRARIES ${core_DEPENDS} gtest)
target_link_libraries(${APP_NAME_LC}-test PRIVATE ${SYSTEM_LDFLAGS} ${_TEST_LIBRARIES} lib${APP_NAME_LC} ${DEPLIBS} ${CMAKE_DL_LIBS})
unset(_TEST_LIBRARIES)
add_dependencies(${APP_NAME_LC}-test ${APP_NAME_LC}-libraries export-files)
-if(WIN32)
- add_precompiled_header(${APP_NAME_LC}-test pch.h ${CMAKE_SOURCE_DIR}/xbmc/platform/win32/pch.cpp PCH_TARGET kodi)
-endif()
# Enable unit-test related targets
if(CORE_HOST_IS_TARGET)