aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilipp Kerling <pkerling@casix.org>2018-01-04 13:09:37 +0100
committerPhilipp Kerling <pkerling@casix.org>2018-01-04 15:37:28 +0100
commitc26404b56118072d6933580908d270b7d6d5ddab (patch)
tree0fae4b98c2feed37f9803d25b06e042683ffc319 /CMakeLists.txt
parentf4803e478b52b7ca8948bc99c9350a143c224f37 (diff)
[cmake] Allow specifying version requirements for dependencies
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcec3151c1..4ed2d1ee2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,9 +102,10 @@ find_package(Threads REQUIRED QUIET)
list(APPEND DEPLIBS ${CMAKE_THREAD_LIBS_INIT})
-foreach(dep ${PLATFORM_REQUIRED_DEPS})
+foreach(depspec ${PLATFORM_REQUIRED_DEPS})
# We need to specify ENABLE_${PLATFORM_REQUIRED_DEPS} in order for the
# optional subdirectory for the specified platform to get built.
+ split_dependency_specification(${depspec} dep version)
string(TOUPPER ${dep} depup)
set(ENABLE_${depup} "ON" CACHE BOOL "Force enabling required ${depup} support" FORCE)
endforeach()