aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRechi <Rechi@users.noreply.github.com>2022-03-13 18:37:06 -0700
committerRechi <Rechi@users.noreply.github.com>2022-03-13 18:37:06 -0700
commitaf0820f4b6681e262a5d98e93c973e3e47920491 (patch)
tree3edc38b7409091b0c35427c9753acf95d0ad4775 /CMakeLists.txt
parentb3156cccd0db85c9dfe90f0c63121e2b9d7a058f (diff)
[cmake] declare directories of external libraries as system headers
This allows the compiler and checker tools to ignore warnings in the library headers.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 123728c2a1..a2dca574db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -271,7 +271,7 @@ endif()
# Generate messages
core_add_subdirs_from_filelist(${CMAKE_SOURCE_DIR}/cmake/messages/flatbuffers/*.txt)
-include_directories(${INCLUDES} ${SYSTEM_INCLUDES})
+include_directories(${INCLUDES} SYSTEM ${SYSTEM_INCLUDES})
add_compile_options(${ARCH_DEFINES} "${SYSTEM_DEFINES}" ${DEP_DEFINES} ${PATH_DEFINES})
set(core_DEPENDS "" CACHE STRING "" FORCE)