aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2023-09-13 09:08:07 +1000
committerfuzzard <fuzzard@kodi.tv>2023-09-13 09:08:07 +1000
commit41e6ed5342627e0b46955487a3b7ed9192e4061d (patch)
tree55493c112bb0aa8e0326b84a69a355542b307021 /CMakeLists.txt
parent1f4ee051090a27f0f37348e8229bdce271ba7036 (diff)
[cmake] Remove XBT_FILES as a dependency of generate-packaging TARGET
Ninja doesnt handle the dependency without a clear indication of where the files are from. As they are generated as part of gen_skin_pack, we already have an order dependency in place so we do not need XBT_FILES
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4df3257a55..8e137c447c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -438,7 +438,7 @@ add_custom_target(gen_skin_pack
# Packaging target. This generates system addon, xbt creation, copy files to build tree
add_custom_target(generate-packaging ALL
- DEPENDS TexturePacker::TexturePacker::Executable export-files gen_skin_pack gen_system_addons ${XBT_FILES})
+ DEPENDS TexturePacker::TexturePacker::Executable export-files gen_skin_pack gen_system_addons)
# Make sure we build any libs before we look to export-files.
# We may need to export some shared libs/data (eg Python)
add_dependencies(export-files ${GLOBAL_TARGET_DEPS})