aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2022-04-25 10:54:48 +1000
committerfuzzard <fuzzard@kodi.tv>2022-04-28 13:20:16 +1000
commitd5b46e864dbef8a3e06c0f680f925331b991b624 (patch)
tree97e016b7cc01c8b3ec8238bd08a58e9e44421832 /CMakeLists.txt
parent2b6cc755abf04aa51192de9f1bfa00dd9ceb075d (diff)
[cmake] rename CORE_HOST_IS_TARGET to HOST_CAN_EXECUTE_TARGET
We are now in a time where some platforms/archs can execute "foreign" (x86_64) arch code locally (Apple via Rosetta, Windows on arm). Rename CORE_HOST_IS_TARGET to HOST_CAN_EXECUTE_TARGET to allow platforms ArchSetup to set and therefore execute tests if desired.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5824f0d20..84e58467f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -392,7 +392,7 @@ else()
endif()
# testing
-if(CORE_HOST_IS_TARGET AND ENABLE_TESTING)
+if(HOST_CAN_EXECUTE_TARGET AND ENABLE_TESTING)
find_package(Gtest)
copy_files_from_filelist_to_buildtree(${CMAKE_SOURCE_DIR}/cmake/installdata/test-reference-data.txt NO_INSTALL)