aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@users.noreply.github.com>2023-06-05 09:08:40 +1000
committerGitHub <noreply@github.com>2023-06-05 09:08:40 +1000
commitd3adb9fedf85332a9a67a5bc4241c9907b7a8afb (patch)
tree846a1a642f20b77a4b906eb7ecb2c47973058090 /CMakeLists.txt
parent7fc9527c6aa94e3a6f7db7a89eef5825e3631e80 (diff)
parent3fb93608deea1dd5b87e0ae9e1d121f951d896e7 (diff)
Merge pull request #23148 from lrusak/linux-audio-params
CAppParamParserLinux: add --audio-backend=<backend> switch
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3a5733dc0..65af0120e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,6 +112,8 @@ endif()
core_find_git_rev(APP_SCMID FULL)
+set(AUDIO_BACKENDS_LIST "" CACHE STRING "Available audio backends")
+
# Dynamically loaded libraries built with the project
add_custom_target(${APP_NAME_LC}-libraries)
set(LIBRARY_FILES "" CACHE STRING "" FORCE)
@@ -255,12 +257,17 @@ endif()
set(outputFilterRegex "addons/xbmc.json")
find_addon_xml_in_files(${outputFilterRegex})
+if(ALSA_FOUND AND PULSEAUDIO_FOUND)
+ list(APPEND AUDIO_BACKENDS_LIST "alsa+pulseaudio")
+endif()
+
# Compile Info
add_custom_command(OUTPUT ${CORE_BUILD_DIR}/xbmc/CompileInfo.cpp
${ADDON_XML_OUTPUTS}
COMMAND ${CMAKE_COMMAND} -DCORE_SOURCE_DIR=${CMAKE_SOURCE_DIR}
-DCORE_SYSTEM_NAME=${CORE_SYSTEM_NAME}
-DCORE_PLATFORM_NAME_LC="${CORE_PLATFORM_NAME_LC}"
+ -DAUDIO_BACKENDS="${AUDIO_BACKENDS_LIST}"
-DCORE_BUILD_DIR=${CORE_BUILD_DIR}
-DCMAKE_BINARY_DIR=${CMAKE_BINARY_DIR}
-DARCH_DEFINES="${ARCH_DEFINES}"