aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLukas Rusak <lorusak@gmail.com>2023-01-06 19:57:00 -0800
committerLukas Rusak <lorusak@gmail.com>2023-01-09 20:37:47 -0800
commitc833e843110e53a37b8a7cfec3552bea032feaeb (patch)
tree820e06de4b2268bb39d994374c58b6756624343d /CMakeLists.txt
parent8fdbdb1890027682eb18685bce586f868a2d35ea (diff)
[cmake] set policy CMP0135 to NEW
This updates the timestamps of of the extracted files see: https://cmake.org/cmake/help/latest/policy/CMP0135.html Signed-off-by: Lukas Rusak <lorusak@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 19881e4708..2739e60c93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,11 @@ if(POLICY CMP0069)
cmake_policy(SET CMP0069 NEW)
endif()
+if(POLICY CMP0135)
+ set(CMAKE_POLICY_DEFAULT_CMP0135 NEW)
+ cmake_policy(SET CMP0135 NEW)
+endif()
+
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules/buildtools)
if(DEPENDS_DIR)