aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@users.noreply.github.com>2023-09-27 07:34:15 +1000
committerGitHub <noreply@github.com>2023-09-27 07:34:15 +1000
commit6763a69993866546132a1c394edbebec6bd3466f (patch)
treeeee556272c530a7cb73881903669051cb7ae1575 /CMakeLists.txt
parentc1fd7324bff6347ef5035cf98b469cdbd0630c1e (diff)
parent97672dd3f9c5f1c2573883888fc52bfa1448cd65 (diff)
Merge pull request #23807 from fuzzard/cmake_multigen_alldep
[Cmake] Create build_internal_depends for MultiConfig Generators
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8eb81cbd8f..caac43f283 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,9 @@ endif()
# Variable to indicate if the project is targeting a Multi Config Generator (VS/Xcode primarily)
get_property(_multiconfig_generator GLOBAL PROPERTY GENERATOR_IS_MULTI_CONFIG)
+if(_multiconfig_generator)
+ add_custom_target(build_internal_depends)
+endif()
# Set CORE_BUILD_DIR
set(CORE_BUILD_DIR build)