aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2022-06-14 21:01:56 +1000
committerfuzzard <fuzzard@kodi.tv>2022-06-17 22:22:43 +1000
commitf68818df375e875f93d05adbb2422b8eb8697f1b (patch)
tree9b4708a2bcdd4922bd9f3827b76535a29ef3ef11 /CMakeLists.txt
parent9ee3e8e61c9dbeb7516759e08af0933ac96eae10 (diff)
[cmake] create lists and utilise core_optional_dep/core_required_dep for build tools
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 16 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2938c11e04..48ad59a81d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,6 +137,22 @@ foreach(depspec ${PLATFORM_REQUIRED_DEPS})
set(ENABLE_${depup} "ON" CACHE BOOL "Force enabling required ${depup} support" FORCE)
endforeach()
+# Required tools. Keep in alphabetical order please
+set(required_buildtools JsonSchemaBuilder
+ TexturePacker
+)
+
+# Optional build tools
+set(optional_buildtools CCache
+ ClangFormat
+ ClangTidy
+ Cppcheck
+ IncludeWhatYouUse)
+
+# Find build tools - Optional and required
+core_optional_dep(${optional_buildtools})
+core_require_dep(${required_buildtools})
+
# Required dependencies. Keep in alphabetical order please
set(required_deps ASS
Cdio
@@ -169,14 +185,9 @@ set(optional_deps Alsa
Bluetooth
Bluray
CAP
- CCache
CEC
- ClangFormat
- ClangTidy
- Cppcheck
Dav1d
DBus
- IncludeWhatYouUse
Iso9660pp
LCMS2
LircClient
@@ -198,10 +209,6 @@ set(optional_deps Alsa
core_optional_dep(${optional_deps})
core_require_dep(${required_deps})
-# Required tools
-find_package(TexturePacker REQUIRED)
-find_package(JsonSchemaBuilder REQUIRED)
-
if(ENABLE_MARIADBCLIENT AND NOT ENABLE_MARIADBCLIENT STREQUAL AUTO AND ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)
MESSAGE(FATAL_ERROR "You can not use MySql and MariaDB at the same time. Disable one by adding -DENABLE_MYSQLCLIENT=OFF or -DENABLE_MARIADBCLIENT=OFF.")
elseif(ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)