aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2018-12-07 11:12:51 +0100
committerwsnipex <wsnipex@a1.net>2018-12-07 21:09:57 +0100
commitcc1527c6b7b32ee47e101cb5fd1ec0be0fbc59a6 (patch)
treeedec180c43a3b7fc24c2bb845616a9a5b3100053 /CMakeLists.txt
parent23701b086233aa44388b64a0fe817e7ba98b6d10 (diff)
[cmake] fix ninja generator when dupbuild=err
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 28024af9fe..d744e42a71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,7 +215,8 @@ endif()
# find all folders containing addon.xml.in
# used to define ADDON_XML_OUTPUTS, ADDON_XML_DEPENDS and ADDON_INSTALL_DATA
# Function defined in ./cmake/scripts/common/Macros.cmake
-find_addon_xml_in_files()
+set(outputFilterRegex "addons/xbmc.json")
+find_addon_xml_in_files(${outputFilterRegex})
# Compile Info
add_custom_command(OUTPUT ${CORE_BUILD_DIR}/xbmc/CompileInfo.cpp