aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWolfgang Schupp <w.schupp@a1.net>2018-06-15 13:51:02 +0200
committerGitHub <noreply@github.com>2018-06-15 13:51:02 +0200
commitd7a7d9913e3bae583f8c3349e8aff8bd833ee61a (patch)
tree9a6d5378f1015ed390c6aa561e1278ff0600c3c5 /CMakeLists.txt
parentc14e34d50cd8cf5025e5f6530a5d0bcac79120db (diff)
parent91e0de19bc55d3306a247116b926dabd0327f413 (diff)
Merge pull request #14017 from wsnipex/ffmpeg-opts
[cmake] pass vaapi and vdpau options to internal ffmpeg
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 508cb12e36..2aff11fb97 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,9 +171,10 @@ set(dyload_optional Bluray
find_package(TexturePacker REQUIRED)
find_package(JsonSchemaBuilder REQUIRED)
-core_require_dep(${required_deps})
+# Check optional deps first, since their availability can influence required ones, e.g. ffmpeg
core_optional_dep(${optional_deps})
core_optional_dyload_dep(${dyload_optional})
+core_require_dep(${required_deps})
if(ENABLE_MARIADBCLIENT AND NOT ENABLE_MARIADBCLIENT STREQUAL AUTO AND ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)
MESSAGE(FATAL_ERROR "You can not use MySql and MariaDB at the same time. Disable one by adding -DENABLE_MYSQLCLIENT=OFF or -DENABLE_MARIADBCLIENT=OFF.")