aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArne Morten Kvarving <arne.morten.kvarving@sintef.no>2018-07-24 11:48:02 +0200
committerArne Morten Kvarving <arne.morten.kvarving@sintef.no>2018-07-25 14:05:10 +0200
commitc79fb23a7d7b8550f236ecbc9d3f0af4e57365e4 (patch)
tree9970fd9d16841eb1f7b9894839ac219a28ef3607 /CMakeLists.txt
parent701244c47244f62402edfce6e1f33f47d2d8cfd3 (diff)
changed: use libfstrcmp
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e51e0aeaa6..0e35189a24 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,6 +57,7 @@ if(UNIX)
option(ENABLE_INTERNAL_CROSSGUID "Enable internal crossguid?" ON)
option(ENABLE_INTERNAL_RapidJSON "Enable internal rapidjson?" OFF)
option(ENABLE_INTERNAL_FMT "Enable internal fmt?" OFF)
+ option(ENABLE_INTERNAL_FSTRCMP "Enable internal fstrcmp?" OFF)
endif()
# System options
if(NOT WIN32)
@@ -118,6 +119,7 @@ set(required_deps ASS
Fmt
FreeType
FriBidi
+ fstrcmp
Iconv
LibDvd
Lzo2
@@ -284,7 +286,7 @@ endif()
# main library (used for main binary and tests)
add_library(lib${APP_NAME_LC} STATIC $<TARGET_OBJECTS:compileinfo>)
-add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg dvdnav crossguid fmt ${PLATFORM_GLOBAL_TARGET_DEPS})
+add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg dvdnav crossguid fmt fstrcmp ${PLATFORM_GLOBAL_TARGET_DEPS})
set_target_properties(lib${APP_NAME_LC} PROPERTIES PREFIX "")
# Other files (IDE)