aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilipp Kerling <pkerling@casix.org>2017-08-12 23:01:49 +0200
committerPhilipp Kerling <pkerling@casix.org>2017-08-16 16:12:02 +0200
commit0a057c342adf57213ecaf3b1c7ede4e782092414 (patch)
tree41aa1a79b0822d50aca8353e53f7326381f6fb13 /CMakeLists.txt
parent40af3bb48e209dc27fb133260953980ce81d892a (diff)
cmake: Enable platforms to add global deps to all targets
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e425e6e5bf..5bb95ec259 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -279,7 +279,7 @@ endif()
# main library (used for main binary and tests)
add_library(lib${APP_NAME_LC} STATIC $<TARGET_OBJECTS:compileinfo>)
set_target_properties(lib${APP_NAME_LC} PROPERTIES PREFIX "")
-add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg dvdnav crossguid)
+add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg dvdnav crossguid ${PLATFORM_GLOBAL_TARGET_DEPS})
# Other files (IDE)
set(OTHER_FILES cmake/README.md)