aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Fedchin <anightik@gmail.com>2017-12-04 15:55:44 +0300
committerAnton Fedchin <anightik@gmail.com>2017-12-08 18:11:59 +0300
commit73538606ad95d8853c2c49ce2ffce1c659f78184 (patch)
tree6f3ed0262e1f5912411a788ee8575812d4d64d45 /CMakeLists.txt
parenta8c2c86e641661f08ff3afd3df951095031c4afa (diff)
[windows] move libdvd from mingwlibs to cmake build tree
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41936a5d15..6b77477b94 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -132,7 +132,6 @@ endif()
if(CORE_SYSTEM_NAME STREQUAL windowsstore)
#uses header only version of Fmt
list(REMOVE_ITEM required_deps Fmt)
- list(REMOVE_ITEM required_deps LibDvd)
endif()
# Optional dependencies. Keep in alphabetical order please
@@ -286,11 +285,7 @@ endif()
# main library (used for main binary and tests)
add_library(lib${APP_NAME_LC} STATIC $<TARGET_OBJECTS:compileinfo>)
-if (CORE_SYSTEM_NAME STREQUAL windowsstore)
- add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg)
-else()
- add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg dvdnav crossguid ${PLATFORM_GLOBAL_TARGET_DEPS})
-endif()
+add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg dvdnav crossguid ${PLATFORM_GLOBAL_TARGET_DEPS})
set_target_properties(lib${APP_NAME_LC} PROPERTIES PREFIX "")
# Other files (IDE)