aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Saraev <stefan@saraev.ca>2017-03-27 22:12:39 +0300
committerStefan Saraev <stefan@saraev.ca>2017-04-07 20:14:12 +0300
commit1d718acfb13b0681805867dc6ce4f9715c0d0216 (patch)
tree59649c7b859ce1dd3d9bf7c7758130d4b25aac4f /CMakeLists.txt
parent984fe69cd6de624f12d454fd5ad8f07080afdb12 (diff)
[cleanup] remove internal rar support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ff1be99ae..24ff1865e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,7 +41,6 @@ set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -x assembler-with-cpp")
option(VERBOSE "Enable verbose output?" OFF)
option(ENABLE_DVDCSS "Enable libdvdcss support?" ON)
option(ENABLE_UPNP "Enable UPnP support?" ON)
-option(ENABLE_NONFREE "Enable non-free components?" ON)
option(ENABLE_AIRTUNES "Enable AirTunes support?" ON)
option(ENABLE_OPTICAL "Enable optical support?" ON)
option(ENABLE_PYTHON "Enable python support?" ON)
@@ -194,10 +193,6 @@ if(ENABLE_UPNP)
list(APPEND DEP_DEFINES "-DUSE_UPNP=1")
endif()
-if(ENABLE_NONFREE)
- list(APPEND DEP_DEFINES "-DHAVE_XBMC_NONFREE=1")
-endif()
-
if(ENABLE_OPTICAL)
list(APPEND DEP_DEFINES -DHAS_DVD_DRIVE)
endif()