aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRechi <Rechi@users.noreply.github.com>2019-03-19 10:25:37 +0100
committerRechi <Rechi@users.noreply.github.com>2019-03-19 10:25:37 +0100
commit7f0efb77aabdd94efb29d5d3be4292092b21e54a (patch)
treeab57be5ee6c0ee64cbb0f543fc0f5456c150fcdf /CMakeLists.txt
parentee01df484a687fef7ade7c0663da515c29a9dc51 (diff)
[cmake] require zlib for all platforms
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c7de554bf..85bce62741 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,10 +134,9 @@ set(required_deps ASS
Sqlite3
TagLib
TinyXML
+ ZLIB
${PLATFORM_REQUIRED_DEPS})
-if(NOT WIN32)
- list(APPEND required_deps ZLIB)
-else()
+if(WIN32)
list(APPEND required_deps D3DX11Effects)
endif()