aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilipp Kerling <pkerling@casix.org>2018-03-15 15:43:53 +0100
committerPhilipp Kerling <pkerling@casix.org>2018-03-23 09:38:51 +0100
commit4e9950b0a0ad9a190fb3c4725817bdda671f5ee7 (patch)
tree6bf422370b14865709c73b806447737032a193e3 /CMakeLists.txt
parent6bc1ad9b1f1bcb67bc3d79830488dd259954bff2 (diff)
Require OpenSSL and consolidate multi-threading initialization
It should make no difference whether curl links OpenSSL statically or dynamically, and having the same code in two places makes no sense.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 150fe9744c..1aafc21a54 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,6 @@ if(UNIX)
option(ENABLE_INTERNAL_CROSSGUID "Enable internal crossguid?" ON)
option(ENABLE_INTERNAL_RapidJSON "Enable internal rapidjson?" OFF)
option(ENABLE_INTERNAL_FMT "Enable internal fmt?" OFF)
- option(ENABLE_OPENSSL "Enable OpenSSL?" ON)
endif()
# System options
if(NOT WIN32)
@@ -122,6 +121,7 @@ set(required_deps Cdio
Iconv
LibDvd
Lzo2
+ OpenSSL
PCRE
RapidJSON
Sqlite3
@@ -193,11 +193,6 @@ if(NOT UDEV_FOUND)
core_optional_dep(LibUSB)
endif()
-if(ENABLE_OPENSSL)
- core_require_dep(OpenSSL)
- list(APPEND DEP_DEFINES "-DHAVE_OPENSSL=1")
-endif()
-
if(ENABLE_UPNP)
list(APPEND DEP_DEFINES "-DHAS_UPNP=1")
endif()