aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilipp Kerling <pkerling@casix.org>2018-10-10 08:52:30 +0200
committerPhilipp Kerling <pkerling@casix.org>2018-10-10 10:03:31 +0200
commitcaa0ce8f0a0381e47f97d41e3b5cf94ae0b4af38 (patch)
treec509d20ecdf27cdd23459547dd6a3838418554bd /CMakeLists.txt
parenta00ae8e730cf961426c583dd1b8b2628869fe15c (diff)
[cmake] Show error when required platform deps are explicitly disabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc5873340f..911560e4e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,6 +107,9 @@ foreach(depspec ${PLATFORM_REQUIRED_DEPS})
# optional subdirectory for the specified platform to get built.
split_dependency_specification(${depspec} dep version)
string(TOUPPER ${dep} depup)
+ if(NOT ${ENABLE_${depup}} STREQUAL AUTO AND NOT ${ENABLE_${depup}})
+ message(WARNING "Your request to disable the dependency ${dep} required on platform ${CORE_PLATFORM_NAME} was ignored. Please choose another platform or add \"-DENABLE_${depup}=ON\" to your CMake command line to resolve this warning.")
+ endif()
set(ENABLE_${depup} "ON" CACHE BOOL "Force enabling required ${depup} support" FORCE)
endforeach()