aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRechi <Rechi@users.noreply.github.com>2018-05-26 18:00:00 +0200
committerRechi <Rechi@users.noreply.github.com>2018-05-26 18:00:00 +0200
commitb51bf4ea2f021e34396e2f187ecf75e13ac1c4b7 (patch)
treefe444b4f8e03d878472b490fe2625f3d024c76bb /CMakeLists.txt
parentbdd283187233c5db680a3ac0d9bdfb434cbccad0 (diff)
link with libass instead of loading it dynamic
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05ae2a6ad3..bc9b96240d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,7 +109,8 @@ foreach(depspec ${PLATFORM_REQUIRED_DEPS})
endforeach()
# Required dependencies. Keep in alphabetical order please
-set(required_deps Cdio
+set(required_deps ASS
+ Cdio
Cpluff
CrossGUID
Curl
@@ -161,9 +162,6 @@ set(optional_deps Alsa
XSLT
${PLATFORM_OPTIONAL_DEPS})
-# Required, dyloaded deps. Keep in alphabetical order please
-set(required_dyload ASS)
-
# Optional, dyloaded deps. Keep in alphabetical order please
set(dyload_optional Bluray
NFS
@@ -175,7 +173,6 @@ find_package(JsonSchemaBuilder REQUIRED)
core_require_dep(${required_deps})
core_optional_dep(${optional_deps})
-core_require_dyload_dep(${required_dyload})
core_optional_dyload_dep(${dyload_optional})
if(ENABLE_MARIADBCLIENT AND NOT ENABLE_MARIADBCLIENT STREQUAL AUTO AND ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)