aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwsnipex <wsnipex@a1.net>2018-06-07 10:17:15 +0200
committerwsnipex <wsnipex@a1.net>2018-06-07 10:17:15 +0200
commit6a0ad8c27cf8f41a368475c4f7d4ba9602542dc6 (patch)
tree756510573144d3f5f13e10a68cd9e9ebda86c2e5 /CMakeLists.txt
parent95da876587c466691eb9fc31b6bfb0c298a8dd8e (diff)
[cmake] pass vaapi and vdpau options to internal ffmpeg
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc9b96240d..5227b77d58 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,9 +171,10 @@ set(dyload_optional Bluray
find_package(TexturePacker REQUIRED)
find_package(JsonSchemaBuilder REQUIRED)
-core_require_dep(${required_deps})
+# Check optional deps first, since their availability can influence required ones, e.g. ffmpeg
core_optional_dep(${optional_deps})
core_optional_dyload_dep(${dyload_optional})
+core_require_dep(${required_deps})
if(ENABLE_MARIADBCLIENT AND NOT ENABLE_MARIADBCLIENT STREQUAL AUTO AND ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)
MESSAGE(FATAL_ERROR "You can not use MySql and MariaDB at the same time. Disable one by adding -DENABLE_MYSQLCLIENT=OFF or -DENABLE_MARIADBCLIENT=OFF.")