aboutsummaryrefslogtreecommitdiff
path: root/packages/demobank-ui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/demobank-ui/Makefile')
-rw-r--r--packages/demobank-ui/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/demobank-ui/Makefile b/packages/demobank-ui/Makefile
new file mode 100644
index 000000000..ae7474e2c
--- /dev/null
+++ b/packages/demobank-ui/Makefile
@@ -0,0 +1,21 @@
+# This Makefile has been placed in the public domain
+
+# Settings from "./configure"
+include .config.mk
+
+all:
+ @echo run \'make install\' to install
+
+spa_dir=$(prefix)/share/taler/demobank-ui
+
+install:
+ pnpm install --frozen-lockfile --filter @gnu-taler/demobank-ui...
+ pnpm run check
+ pnpm run build
+ install -d $(spa_dir)
+ install ./dist/index.css $(spa_dir)
+ install ./dist/index.css.map $(spa_dir)
+ install ./dist/index.js $(spa_dir)
+ install ./dist/index.js.map $(spa_dir)
+ install ./dist/index.html $(spa_dir)
+