aboutsummaryrefslogtreecommitdiff
path: root/packages/aml-backoffice-ui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/aml-backoffice-ui/Makefile')
-rw-r--r--packages/aml-backoffice-ui/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/aml-backoffice-ui/Makefile b/packages/aml-backoffice-ui/Makefile
new file mode 100644
index 000000000..ddbef73b3
--- /dev/null
+++ b/packages/aml-backoffice-ui/Makefile
@@ -0,0 +1,17 @@
+# This Makefile has been placed in the public domain
+
+# Settings from "./configure"
+include .config.mk
+
+all:
+ @echo run \'make install\' to install
+
+spa_dir=$(prefix)/share/taler/aml-backoffice-ui
+
+install:
+ pnpm install --frozen-lockfile --filter @gnu-taler/aml-backoffice-ui...
+ pnpm run check
+ pnpm run build
+ install -d $(spa_dir)
+ install ./dist/prod/* $(spa_dir)
+