aboutsummaryrefslogtreecommitdiff
path: root/packages/taler-harness
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2023-06-21 09:44:02 +0200
committerFlorian Dold <florian@dold.me>2023-06-21 09:44:02 +0200
commit709adb2d48c8e3c393d2ebfe2482b9947cd2c1e9 (patch)
tree47df9120b663a01c2d83ab90e5c6a7a9675ef206 /packages/taler-harness
parenta0e0c5c4a61329886b22e11ccac7626d8861bf79 (diff)
downloadwallet-core-709adb2d48c8e3c393d2ebfe2482b9947cd2c1e9.tar.xz
repo: fix Makefiles / top-level 'make install' target
Diffstat (limited to 'packages/taler-harness')
-rw-r--r--packages/taler-harness/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/packages/taler-harness/Makefile b/packages/taler-harness/Makefile
index a7dc2d049..ed8365dc8 100644
--- a/packages/taler-harness/Makefile
+++ b/packages/taler-harness/Makefile
@@ -1,7 +1,13 @@
# This Makefile has been placed in the public domain.
--include ../../.config.mk
-#include .config.mk
+ifeq ($(TOPLEVEL), yes)
+ $(info top-level build)
+ -include ../../.config.mk
+else
+ $(info package-level build)
+ -include ../../.config.mk
+ -include .config.mk
+endif
$(info prefix is $(prefix))