aboutsummaryrefslogtreecommitdiff
path: root/packages/taler-harness/Makefile
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2022-12-23 12:59:29 +0100
committerFlorian Dold <florian@dold.me>2022-12-23 13:19:41 +0100
commit083c4cf5d96314c44dd716cf3cc931e95b651bbd (patch)
tree7f15a46224d5dfe495e26dc6ec66996c889498ff /packages/taler-harness/Makefile
parentd98711cb51d13bb2da3682014c7c6e75d7fbb4f0 (diff)
downloadwallet-core-083c4cf5d96314c44dd716cf3cc931e95b651bbd.tar.xz
spill extra functionality from wallet-cli into taler-harness
We want to keep taler-wallet-cli smaller and have fewer dependencies.
Diffstat (limited to 'packages/taler-harness/Makefile')
-rw-r--r--packages/taler-harness/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/taler-harness/Makefile b/packages/taler-harness/Makefile
new file mode 100644
index 000000000..85c146641
--- /dev/null
+++ b/packages/taler-harness/Makefile
@@ -0,0 +1,30 @@
+# This Makefile has been placed in the public domain.
+
+-include ../../.config.mk
+include .config.mk
+
+$(info prefix is $(prefix))
+
+all:
+ @echo use 'make install' to build and install taler-harness
+
+ifndef prefix
+.PHONY: warn-noprefix install
+warn-noprefix:
+ @echo "no prefix configured, did you run ./configure?"
+install: warn-noprefix
+else
+install_target = $(prefix)/lib/taler-harness
+.PHONY: install install-nodeps
+install:
+ pnpm install --frozen-lockfile --filter @gnu-taler/taler-harness...
+ install -d $(prefix)/bin
+ install -d $(install_target)/bin
+ install -d $(install_target)/node_modules/taler-harness
+ install -d $(install_target)/node_modules/taler-harness/bin
+ install -d $(install_target)/node_modules/taler-harness/dist
+ install ./dist/taler-harness-bundled.cjs $(install_target)/node_modules/taler-harness/dist/
+ install ./dist/taler-harness-bundled.cjs.map $(install_target)/node_modules/taler-harness/dist/
+ install ./bin/taler-harness.mjs $(install_target)/node_modules/taler-harness/bin/
+ ln -sf $(install_target)/node_modules/taler-harness/bin/taler-harness.mjs $(prefix)/bin/taler-harness
+endif