aboutsummaryrefslogtreecommitdiff
path: root/packages/demobank-ui/Makefile
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2022-10-31 12:02:09 +0100
committerFlorian Dold <florian@dold.me>2022-10-31 12:02:09 +0100
commit9cc20fc5af8467c7d97338b3dc0445a9ffbf05da (patch)
treee02f3cd180d99ba2b4b6269e1787d06e148fe411 /packages/demobank-ui/Makefile
parentf929cbb808e02f15074a5f3e1fc4d43d92291520 (diff)
downloadwallet-core-9cc20fc5af8467c7d97338b3dc0445a9ffbf05da.tar.xz
repo: GNU-style build system for demobank-ui package
Diffstat (limited to 'packages/demobank-ui/Makefile')
-rw-r--r--packages/demobank-ui/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/demobank-ui/Makefile b/packages/demobank-ui/Makefile
new file mode 100644
index 000000000..ae7474e2c
--- /dev/null
+++ b/packages/demobank-ui/Makefile
@@ -0,0 +1,21 @@
+# This Makefile has been placed in the public domain
+
+# Settings from "./configure"
+include .config.mk
+
+all:
+ @echo run \'make install\' to install
+
+spa_dir=$(prefix)/share/taler/demobank-ui
+
+install:
+ pnpm install --frozen-lockfile --filter @gnu-taler/demobank-ui...
+ pnpm run check
+ pnpm run build
+ install -d $(spa_dir)
+ install ./dist/index.css $(spa_dir)
+ install ./dist/index.css.map $(spa_dir)
+ install ./dist/index.js $(spa_dir)
+ install ./dist/index.js.map $(spa_dir)
+ install ./dist/index.html $(spa_dir)
+