aboutsummaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorpriscilla <priscilla.huang@efrei.net>2022-12-21 09:31:36 -0500
committerpriscilla <priscilla.huang@efrei.net>2022-12-21 09:31:59 -0500
commit97ccd1b689b0ce5980d76ffb9c5624bc7f6c6723 (patch)
tree554fa0355f3bf64e3458c8a7f9a3d20adfc0848c /src
parentac4225f09f31dd59135c874f8658e3c514b9d131 (diff)
api using template
Diffstat (limited to 'src')
-rw-r--r--src/include/taler_merchant_service.h41
-rw-r--r--src/lib/Makefile.am1
-rw-r--r--src/lib/merchant_api_post_templates.c1
-rw-r--r--src/lib/merchant_api_post_using_templates.c227
4 files changed, 269 insertions, 1 deletions
diff --git a/src/include/taler_merchant_service.h b/src/include/taler_merchant_service.h
index 09292c18..c5bef549 100644
--- a/src/include/taler_merchant_service.h
+++ b/src/include/taler_merchant_service.h
@@ -4370,6 +4370,47 @@ void
TALER_MERCHANT_template_delete_cancel (
struct TALER_MERCHANT_TemplateDeleteHandle *tdh);
+/**
+ * Function called with the result of the POST /using-templates operation.
+ *
+ * @param cls closure
+ * @param hr HTTP response details
+ */
+typedef void
+(*TALER_MERCHANT_UsingTemplatesPostCallback)(
+ void *cls,
+ const struct TALER_MERCHANT_HttpResponse *hr);
+
+/**
+ * Make a POST /using-templates request to add an using template
+ *
+ * @param ctx the context
+ * @param backend_url HTTP base URL for the backend
+ * @param summary summary of the using template
+ * @param amount to pay given by the customer
+ * @param cb function to call with the backend's result
+ * @param cb_cls closure for @a cb
+ * @return the request handle; NULL upon error
+ */
+struct TALER_MERCHANT_UsingTemplatesPostHandle *
+TALER_MERCHANT_using_templates_post (
+ struct GNUNET_CURL_Context *ctx,
+ const char *backend_url,
+ const char *summary,
+ struct TALER_Amount amount,
+ TALER_MERCHANT_UsingTemplatesPostCallback cb,
+ void *cb_cls);
+
+
+/**
+ * Cancel POST /using-templates operation.
+ *
+ * @param utph operation to cancel
+ */
+void
+TALER_MERCHANT_using_templates_post_cancel (
+ struct TALER_MERCHANT_UsingTemplatesPostHandle *utph);
+
/* ********************* /webhooks *********************** */
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 7d212c3b..7451b24d 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -58,6 +58,7 @@ libtalermerchant_la_SOURCES = \
merchant_api_post_reserves.c \
merchant_api_post_transfers.c \
merchant_api_post_templates.c \
+ merchant_api_post_using_templates.c \
merchant_api_post_webhooks.c \
merchant_api_tip_authorize.c \
merchant_api_tip_pickup.c \
diff --git a/src/lib/merchant_api_post_templates.c b/src/lib/merchant_api_post_templates.c
index 002896ed..300039a4 100644
--- a/src/lib/merchant_api_post_templates.c
+++ b/src/lib/merchant_api_post_templates.c
@@ -68,7 +68,6 @@ struct TALER_MERCHANT_TemplatesPostHandle
* Minor context that holds body and headers.
*/
struct TALER_CURL_PostContext post_ctx;
-
};
diff --git a/src/lib/merchant_api_post_using_templates.c b/src/lib/merchant_api_post_using_templates.c
new file mode 100644
index 00000000..278fcac8
--- /dev/null
+++ b/src/lib/merchant_api_post_using_templates.c
@@ -0,0 +1,227 @@
+/*
+ This file is part of TALER
+ Copyright (C) 2020-2021 Taler Systems SA
+
+ TALER is free software; you can redistribute it and/or modify
+ it under the terms of the GNU Lesser General Public License as
+ published by the Free Software Foundation; either version 2.1,
+ or (at your option) any later version.
+
+ TALER is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General
+ Public License along with TALER; see the file COPYING.LGPL.
+ If not, see <http://www.gnu.org/licenses/>
+*/
+/**
+ * @file merchant_api_post_using_templates.c
+ * @brief Implementation of the POST /using_templates request
+ * of the merchant's HTTP API
+ * @author Priscilla HUANG
+ */
+#include "platform.h"
+#include <curl/curl.h>
+#include <jansson.h>
+#include <microhttpd.h> /* just for HTTP status codes */
+#include <gnunet/gnunet_util_lib.h>
+#include "taler_merchant_service.h"
+#include "merchant_api_curl_defaults.h"
+#include <taler/taler_json_lib.h>
+#include <taler/taler_curl_lib.h>
+
+
+/**
+ * Handle for a POST /templates/$ID operation.
+ */
+struct TALER_MERCHANT_UsingTemplatesPostHandle
+{
+
+ /**
+ * The url for this request.
+ */
+ char *url;
+
+ /**
+ * Handle for the request.
+ */
+ struct GNUNET_CURL_Job *job;
+
+ /**
+ * Function to call with the result.
+ */
+ TALER_MERCHANT_UsingTemplatesPostCallback cb;
+
+ /**
+ * Closure for @a cb.
+ */
+ void *cb_cls;
+
+ /**
+ * Reference to the execution context.
+ */
+ struct GNUNET_CURL_Context *ctx;
+
+ /**
+ * Minor context that holds body and headers.
+ */
+ struct TALER_CURL_PostContext post_ctx;
+};
+
+/**
+ * Function called when we're done processing the
+ * HTTP POST /using-templates request.
+ *
+ * @param cls the `struct TALER_MERCHANT_UsingTemplatesPostHandle`
+ * @param response_code HTTP response code, 0 on error
+ * @param response response body, NULL if not in JSON
+ */
+static void
+handle_post_using_templates_finished (void *cls,
+ long response_code,
+ const void *response)
+{
+ struct TALER_MERCHANT_UsingTemplatesPostHandle *utph = cls;
+ const json_t *json = response;
+ struct TALER_MERCHANT_HttpResponse hr = {
+ .http_status = (unsigned int) response_code,
+ .reply = json
+ };
+
+ utph->job = NULL;
+ GNUNET_log (GNUNET_ERROR_TYPE_INFO,
+ "POST /using-templates completed with response code %u\n",
+ (unsigned int) response_code);
+ switch (response_code)
+ {
+ case 0:
+ hr.ec = TALER_EC_GENERIC_INVALID_RESPONSE;
+ break;
+ case MHD_HTTP_NO_CONTENT:
+ break;
+ case MHD_HTTP_BAD_REQUEST:
+ hr.ec = TALER_JSON_get_error_code (json);
+ hr.hint = TALER_JSON_get_error_hint (json);
+ /* This should never happen, either us
+ * or the merchant is buggy (or API version conflict);
+ * just pass JSON reply to the application */
+ break;
+ case MHD_HTTP_UNAUTHORIZED:
+ hr.ec = TALER_JSON_get_error_code (json);
+ hr.hint = TALER_JSON_get_error_hint (json);
+ /* Nothing really to verify, merchant says we need to authenticate. */
+ break;
+ case MHD_HTTP_FORBIDDEN:
+ hr.ec = TALER_JSON_get_error_code (json);
+ hr.hint = TALER_JSON_get_error_hint (json);
+ /* Nothing really to verify, merchant says we tried to abort the payment
+ * after it was successful. We should pass the JSON reply to the
+ * application */
+ break;
+ case MHD_HTTP_NOT_FOUND:
+ hr.ec = TALER_JSON_get_error_code (json);
+ hr.hint = TALER_JSON_get_error_hint (json);
+ /* Nothing really to verify, this should never
+ happen, we should pass the JSON reply to the
+ application */
+ break;
+ case MHD_HTTP_CONFLICT:
+ hr.ec = TALER_JSON_get_error_code (json);
+ hr.hint = TALER_JSON_get_error_hint (json);
+ break;
+ case MHD_HTTP_INTERNAL_SERVER_ERROR:
+ hr.ec = TALER_JSON_get_error_code (json);
+ hr.hint = TALER_JSON_get_error_hint (json);
+ /* Server had an internal issue; we should retry,
+ but this API leaves this to the application */
+ break;
+ default:
+ TALER_MERCHANT_parse_error_details_ (json,
+ response_code,
+ &hr);
+ /* unexpected response code */
+ GNUNET_log (GNUNET_ERROR_TYPE_ERROR,
+ "Unexpected response code %u/%d\n",
+ (unsigned int) response_code,
+ (int) hr.ec);
+ GNUNET_break_op (0);
+ break;
+ } /* end of the switch */
+ utph->cb (utph->cb_cls,
+ &hr);
+ TALER_MERCHANT_using_templates_post_cancel (utph);
+}
+
+
+struct TALER_MERCHANT_UsingTemplatesPostHandle *
+TALER_MERCHANT_using_templates_post (
+ struct GNUNET_CURL_Context *ctx,
+ const char *backend_url,
+ const char *summary,
+ struct TALER_Amount amount,
+ TALER_MERCHANT_UsingTemplatesPostCallback cb,
+ void *cb_cls)
+{
+ struct TALER_MERCHANT_UsingTemplatesPostHandle *utph;
+ json_t *req_obj;
+
+ req_obj = GNUNET_JSON_PACK (
+ GNUNET_JSON_pack_allow_null (
+ GNUNET_JSON_pack_string ("summary",
+ summary)),
+ GNUNET_JSON_pack_allow_null (
+ TALER_JSON_pack_amount ("amount",
+ &amount)));
+ utph = GNUNET_new (struct TALER_MERCHANT_UsingTemplatesPostHandle);
+ utph->ctx = ctx;
+ utph->cb = cb;
+ utph->cb_cls = cb_cls;
+ utph->url = TALER_url_join (backend_url,
+ "/templates",
+ NULL);
+ if (NULL == utph->url)
+ {
+ GNUNET_log (GNUNET_ERROR_TYPE_ERROR,
+ "Could not construct request URL.\n");
+ json_decref (req_obj);
+ GNUNET_free (utph);
+ return NULL;
+ }
+ {
+ CURL *eh;
+
+ eh = TALER_MERCHANT_curl_easy_get_ (utph->url);
+ GNUNET_assert (GNUNET_OK ==
+ TALER_curl_easy_post (&utph->post_ctx,
+ eh,
+ req_obj));
+ json_decref (req_obj);
+ utph->job = GNUNET_CURL_job_add2 (ctx,
+ eh,
+ utph->post_ctx.headers,
+ &handle_post_using_templates_finished,
+ utph);
+ GNUNET_assert (NULL != utph->job);
+ }
+ return utph;
+}
+
+
+void
+TALER_MERCHANT_using_templates_post_cancel (
+ struct TALER_MERCHANT_UsingTemplatesPostHandle *utph)
+{
+ if (NULL != utph->job)
+ {
+ GNUNET_CURL_job_cancel (utph->job);
+ utph->job = NULL;
+ }
+ TALER_curl_easy_post_finished (&utph->post_ctx);
+ GNUNET_free (utph->url);
+ GNUNET_free (utph);
+}
+
+
+/* end of merchant_api_post_using_templates.c */