aboutsummaryrefslogtreecommitdiff
path: root/src/backend/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2023-05-03 20:18:37 +0200
committerChristian Grothoff <christian@grothoff.org>2023-05-03 20:18:37 +0200
commitbce6a266ed4e273e40c90ecf68d7e1444f211526 (patch)
treebfc36584202fecbae5c1bb9a54330594019cf4e0 /src/backend/Makefile.am
parent02807679d45c7160d74349fbea59792459520b26 (diff)
get new taler-merchant-exchange helper to build
Diffstat (limited to 'src/backend/Makefile.am')
-rw-r--r--src/backend/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/backend/Makefile.am b/src/backend/Makefile.am
index 9da9164e..4edca6ac 100644
--- a/src/backend/Makefile.am
+++ b/src/backend/Makefile.am
@@ -16,6 +16,7 @@ EXTRA_DIST = \
$(pkgcfg_DATA)
bin_PROGRAMS = \
+ taler-merchant-exchange \
taler-merchant-httpd \
taler-merchant-webhook \
taler-merchant-wirewatch
@@ -155,6 +156,23 @@ taler_merchant_httpd_CFLAGS = \
$(AM_CFLAGS)
+taler_merchant_exchange_SOURCES = \
+ taler-merchant-exchange.c
+taler_merchant_exchange_LDADD = \
+ $(top_builddir)/src/backenddb/libtalermerchantdb.la \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -ltalerpq \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -lcurl \
+ $(XLIB)
+taler_merchant_exchange_CFLAGS = \
+ $(AM_CFLAGS)
+
+
taler_merchant_webhook_SOURCES = \
taler-merchant-webhook.c
taler_merchant_webhook_LDADD = \