aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThien-Thi Nguyen <ttn@gnuvola.org>2022-03-19 07:55:24 -0400
committerThien-Thi Nguyen <ttn@gnuvola.org>2022-03-19 07:55:39 -0400
commitc1d7578ee4d8a061c6b0a7bc97c6cbda7e320001 (patch)
tree2425bb302596d43736f488fa050f59db3ed8aff1 /configure.ac
parentbe45eccd893c8287312a78ae476e181f06b76dbb (diff)
[build int] Use ‘MHD_VERSION_AT_LEAST’
* configure.ac (microhttpd): Delete shell var. (MHD_start_daemon): Delete AC_CHECK_LIB. (MHD_VERSION_AT_LEAST): New macro call.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index dd3943be..f6cdf6c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,7 +132,6 @@ AC_CHECK_HEADERS([gnunet/gnunet_pq_lib.h],
AM_CONDITIONAL(HAVE_GNUNETPQ, test x$libgnunetpq = x1)
# check for libmicrohttpd
-microhttpd=0
AC_MSG_CHECKING([for microhttpd])
AC_ARG_WITH([microhttpd],
[AS_HELP_STRING([--with-microhttpd=PFX], [base of microhttpd installation])],
@@ -144,13 +143,7 @@ AS_CASE([$with_microhttpd],
[no], [AC_MSG_ERROR([--with-microhttpd is required])],
[LDFLAGS="-L$with_microhttpd/lib $LDFLAGS"
CPPFLAGS="-I$with_microhttpd/include $CPPFLAGS"])
-AC_CHECK_LIB(microhttpd,MHD_start_daemon,
- [AC_CHECK_HEADER([microhttpd.h],[microhttpd=1])])
-AS_IF([test $microhttpd = 0],
- [AC_MSG_ERROR([[
-***
-*** You need libmicrohttpd to build this program.
-*** ]])])
+MHD_VERSION_AT_LEAST([0.9.39])
jansson=0
PKG_CHECK_MODULES([JANSSON], [jansson >= 2.3],