aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2024-02-01 23:20:18 +0100
committerChristian Grothoff <christian@grothoff.org>2024-02-01 23:20:18 +0100
commita867291ea863948c604ebeeb1f6ffd3e684bb75b (patch)
tree37bffa0d6ab7d7d358deae6d25a4eb1c7a848ee5 /configure.ac
parentc3fece4a3b521dc9694ca09b89fd20370f57b8bf (diff)
add TOTP key and method validation, allow strings to be specified in the TOTP method, bump protocol to v7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c0cb654..a0dc66bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,6 +241,7 @@ AS_CASE([$with_exchange],
[no], [AC_MSG_ERROR([--with-exchange is required])],
[LDFLAGS="-L$with_exchange/lib $LDFLAGS"
CPPFLAGS="-I$with_exchange/include $CPPFLAGS $POSTGRESQL_CPPFLAGS"])
+
AC_CHECK_HEADERS([taler/taler_util.h],
[AC_CHECK_LIB([talerutil], [TALER_denom_ewv_copy], libtalerutil=1)])
AM_CONDITIONAL(HAVE_TALERUTIL, test x$libtalerutil = x1)
@@ -252,6 +253,18 @@ AS_IF([test $libtalerutil != 1],
*** https://taler.net
*** ]])])
+libtalerjson=0
+AC_CHECK_HEADERS([taler/taler_json_lib.h],
+ [AC_CHECK_LIB([talerjson], [TALER_JSON_spec_otp_type], libtalerjson=1)])
+AM_CONDITIONAL(HAVE_TALERJSON, test x$libtalerjson = x1)
+AS_IF([test $libtalerjson != 1],
+ [AC_MSG_ERROR([[
+***
+*** You need libtalerjson >= 0.9.4 to build this program.
+*** This library is part of the GNU Taler exchange, available at
+*** https://taler.net
+*** ]])])
+
# Check for Taler's libtalerpq