aboutsummaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index b70289512..08c2ad29d 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -144,6 +144,7 @@ check_PROGRAMS = \
test_bank_api_with_pybank \
test_exchange_api \
test_exchange_api_keys_cherry_picking \
+ test_exchange_api_revocation \
test_exchange_api_overlapping_keys_bug \
test_taler_exchange_aggregator-postgres \
test_taler_exchange_wirewatch-postgres
@@ -212,6 +213,20 @@ test_exchange_api_LDADD = \
-lgnunetutil \
-ljansson
+test_exchange_api_revocation_SOURCES = \
+ test_exchange_api_revocation.c
+test_exchange_api_revocation_LDADD = \
+ libtalertesting.la \
+ libtalerexchange.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
test_exchange_api_keys_cherry_picking_SOURCES = \
test_exchange_api_keys_cherry_picking.c
test_exchange_api_keys_cherry_picking_LDADD = \