aboutsummaryrefslogtreecommitdiff
path: root/src/exchange-tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exchange-tools/Makefile.am')
-rw-r--r--src/exchange-tools/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/src/exchange-tools/Makefile.am b/src/exchange-tools/Makefile.am
index 9509e20db..5103e3ae8 100644
--- a/src/exchange-tools/Makefile.am
+++ b/src/exchange-tools/Makefile.am
@@ -67,6 +67,20 @@ taler_exchange_dbinit_CPPFLAGS = \
$(POSTGRESQL_CPPFLAGS)
+# Testcases
+
+AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
+
+check_SCRIPTS = \
+ test_taler_exchange_keyup.sh
+
+TESTS = \
+ $(check_SCRIPTS)
+
+# Distribution
+
EXTRA_DIST = \
- $(pkgcfg_DATA) \
- key-helper.c
+ test_taler_exchange_httpd_home/.local/share/taler/exchange/offline-keys/master.priv \
+ test_taler_exchange_httpd.conf \
+ $(check_SCRIPTS) \
+ $(pkgcfg_DATA)