aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-02-11 11:46:42 +0100
committerChristian Grothoff <christian@grothoff.org>2022-02-11 11:46:42 +0100
commit3b9d67a6f8a501bed0a24354bdba1b97a77d1320 (patch)
treea4f336bbfbc5c53907ff9918e8df3f9c48c99c9e /src/testing/Makefile.am
parent0995bdd1d05356ed5f97954449f5a5c74a41bdc5 (diff)
downloadexchange-3b9d67a6f8a501bed0a24354bdba1b97a77d1320.tar.xz
-get twisted tests to pass
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 1704f3cb4..a6b582709 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -136,7 +136,8 @@ check_PROGRAMS = \
test_taler_exchange_wirewatch-postgres
if HAVE_TWISTER
check_PROGRAMS += \
- test_exchange_api_twisted \
+ test_exchange_api_twisted_cs \
+ test_exchange_api_twisted_rsa \
test_bank_api_with_fakebank_twisted \
test_bank_api_with_pybank_twisted
endif
@@ -413,9 +414,27 @@ test_taler_exchange_wirewatch_postgres_LDADD = \
-lpthread \
$(XLIB)
-test_exchange_api_twisted_SOURCES = \
+test_exchange_api_twisted_cs_SOURCES = \
test_exchange_api_twisted.c
-test_exchange_api_twisted_LDADD = \
+test_exchange_api_twisted_cs_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ libtalertesting.la \
+ libtalertwistertesting.la \
+ $(top_builddir)/src/lib/libtalerexchange.la \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunettesting \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
+test_exchange_api_twisted_rsa_SOURCES = \
+ test_exchange_api_twisted.c
+test_exchange_api_twisted_rsa_LDADD = \
$(LIBGCRYPT_LIBS) \
libtalertesting.la \
libtalertwistertesting.la \
@@ -500,7 +519,8 @@ EXTRA_DIST = \
test_exchange_api_keys_cherry_picking_home/.local/share/taler/exchange/wirefees/x-taler-bank.fee \
test_exchange_api-cs.conf \
test_exchange_api-rsa.conf \
- test_exchange_api_twisted.conf \
+ test_exchange_api_twisted-cs.conf \
+ test_exchange_api_twisted-rsa.conf \
test_exchange_api_keys_cherry_picking-cs.conf \
test_exchange_api_keys_cherry_picking-rsa.conf \
test_exchange_api_expire_reserve_now-cs.conf \