aboutsummaryrefslogtreecommitdiff
path: root/src/mint-lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-04-13 13:57:38 +0200
committerChristian Grothoff <christian@grothoff.org>2015-04-13 13:57:38 +0200
commit93bc450db36ebb41bfcc1c0d7edf5cfedbcf0741 (patch)
tree8924deecb33faf881d72b8a8ce72dd930e4cbfc8 /src/mint-lib/Makefile.am
parent2310a3f4747edf100b4c96737426239c893a04a9 (diff)
downloadexchange-93bc450db36ebb41bfcc1c0d7edf5cfedbcf0741.tar.xz
enable code coverage configure option
Diffstat (limited to 'src/mint-lib/Makefile.am')
-rw-r--r--src/mint-lib/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/mint-lib/Makefile.am b/src/mint-lib/Makefile.am
index f91ca32c1..e6e25b046 100644
--- a/src/mint-lib/Makefile.am
+++ b/src/mint-lib/Makefile.am
@@ -1,6 +1,11 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
lib_LTLIBRARIES = \
libtalermint.la
@@ -14,7 +19,7 @@ libtalermint_la_SOURCES = \
libtalermint_la_LIBADD = \
-lgnunetutil \
-ljansson \
- -lcurl
+ -lcurl $(XLIB)
check_PROGRAMS = \
test_mint_api