aboutsummaryrefslogtreecommitdiff
path: root/src/json/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2024-07-24 17:43:07 +0200
committerChristian Grothoff <christian@grothoff.org>2024-07-29 12:18:47 +0200
commit84d82e110511cc74061e4e210caa3389d0345b39 (patch)
treea32f2dc21bd0cf2831d6988e8b39bc3d5f562589 /src/json/Makefile.am
parentab74f09dfc9f97d288351a5aa28b37be04f7ed6c (diff)
move TALER_JSON_ symbols into libtalerjson where they belong
Diffstat (limited to 'src/json/Makefile.am')
-rw-r--r--src/json/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/src/json/Makefile.am b/src/json/Makefile.am
index 200afa714..492a4ed39 100644
--- a/src/json/Makefile.am
+++ b/src/json/Makefile.am
@@ -10,6 +10,7 @@ lib_LTLIBRARIES = \
libtalerjson.la
libtalerjson_la_SOURCES = \
+ conversion.c \
i18n.c \
json.c \
json_helper.c \
@@ -28,16 +29,30 @@ libtalerjson_la_LIBADD = \
$(XLIB)
TESTS = \
+ test_conversion \
test_json
check_PROGRAMS= \
+ test_conversion \
test_json
test_json_SOURCES = \
test_json.c
test_json_LDADD = \
- $(top_builddir)/src/json/libtalerjson.la \
+ libtalerjson.la \
-lgnunetjson \
$(top_builddir)/src/util/libtalerutil.la \
-lgnunetutil \
-ljansson
+
+test_conversion_SOURCES = \
+ test_conversion.c
+test_conversion_LDADD = \
+ libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson
+
+EXTRA_DIST = \
+ test_conversion.sh