aboutsummaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorJoseph <Joseph.xu@efrei.net>2022-12-28 09:37:33 -0500
committerJoseph <Joseph.xu@efrei.net>2022-12-28 09:37:47 -0500
commit2f993d3ee32ac614a8f0b405fc3177c3d33feba9 (patch)
treebe78bfbeed484f0625a6a68feae40308c454df90 /src/exchangedb/Makefile.am
parentf864d66d930690449e855d0a7aa0b146174f4388 (diff)
downloadexchange-2f993d3ee32ac614a8f0b405fc3177c3d33feba9.tar.xz
populate denom-coin-dep
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am27
1 files changed, 25 insertions, 2 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 6955a0af9..694ac8089 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -283,13 +283,15 @@ check_PROGRAMS = \
bench-db-postgres\
perf-exchangedb-reserves-in-insert-postgres\
test-exchangedb-by-j-postgres\
- test-exchangedb-batch-reserves-in-insert-postgres
+ test-exchangedb-batch-reserves-in-insert-postgres\
+ test-exchangedb-populate-table-postgres
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
TESTS = \
test-exchangedb-postgres\
test-exchangedb-by-j-postgres\
perf-exchangedb-reserves-in-insert-postgres\
- test-exchangedb-batch-reserves-in-insert-postgres
+ test-exchangedb-batch-reserves-in-insert-postgres\
+ test-exchangedb-populate-table-postgres
test_exchangedb_postgres_SOURCES = \
@@ -363,6 +365,27 @@ bench_db_postgres_LDADD = \
-lgnunetutil \
$(XLIB)
+test_exchangedb_populate_table_postgres_SOURCES = \
+ test_exchangedb_populate_table.c
+test_exchangedb_populate_table_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -ljansson \
+ -lgnunetjson \
+ -lgnunetutil \
+ $(XLIB)
+
+bench_db_postgres_SOURCES = \
+ bench_db.c
+bench_db_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -lgnunetpq \
+ -lgnunetutil \
+ $(XLIB)
EXTRA_test_exchangedb_postgres_DEPENDENCIES = \
libtaler_plugin_exchangedb_postgres.la