aboutsummaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorMarco Boss <bossm8@bfh.ch>2022-03-31 17:00:44 +0200
committerMarco Boss <bossm8@bfh.ch>2022-03-31 17:00:44 +0200
commit0cf9a9984ce733d8315057b810bfda90cec5c04a (patch)
tree767e0d72b2a3dcc8b4cbd2cea5cadd1c6139492e /src/exchangedb/Makefile.am
parenteadee56dcf9d2fed8b8e94d271db31e3c3832cfa (diff)
downloadexchange-0cf9a9984ce733d8315057b810bfda90cec5c04a.tar.xz
add sharding logic
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 2eb1eb0ad..3df0653ad 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -19,9 +19,19 @@ sql_DATA = \
benchmark-0001.sql \
exchange-0000.sql \
exchange-0001.sql \
- partition-0001.sql \
+ shard-0001.sql \
drop0001.sql
+BUILT_SOURCES = \
+ shard-0001.sql \
+ exchange-0001.sql
+
+exchange-0001.sql: common-0001.sql exchange-0001-part.sql
+ cat common-0001.sql exchange-0001-part.sql >$@
+
+shard-0001.sql: common-0001.sql
+ cp common-0001.sql $@
+
EXTRA_DIST = \
exchangedb.conf \
exchangedb-postgres.conf \