aboutsummaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-12-29 10:10:25 +0100
committerChristian Grothoff <christian@grothoff.org>2022-12-29 10:10:25 +0100
commitfa840f7071da56c4794c887b813ca2a6f491f836 (patch)
tree7b126d737aa1fdc3df2ea60f76540af6011ea049 /src/exchangedb/Makefile.am
parent5828eead705965b5ac87cfad78636b1363b16396 (diff)
parent915d6ddfaa638a9759766eaf69dfef7e8e17474b (diff)
downloadexchange-fa840f7071da56c4794c887b813ca2a6f491f836.tar.xz
Merge branch 'master' of git+ssh://git.taler.net/exchange
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am27
1 files changed, 25 insertions, 2 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 4adb4180c..c11828d0e 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -284,13 +284,15 @@ check_PROGRAMS = \
bench-db-postgres\
perf-exchangedb-reserves-in-insert-postgres\
test-exchangedb-by-j-postgres\
- test-exchangedb-batch-reserves-in-insert-postgres
+ test-exchangedb-batch-reserves-in-insert-postgres\
+ test-exchangedb-populate-table-postgres
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
TESTS = \
test-exchangedb-postgres\
test-exchangedb-by-j-postgres\
perf-exchangedb-reserves-in-insert-postgres\
- test-exchangedb-batch-reserves-in-insert-postgres
+ test-exchangedb-batch-reserves-in-insert-postgres\
+ test-exchangedb-populate-table-postgres
test_exchangedb_postgres_SOURCES = \
@@ -364,6 +366,27 @@ bench_db_postgres_LDADD = \
-lgnunetutil \
$(XLIB)
+test_exchangedb_populate_table_postgres_SOURCES = \
+ test_exchangedb_populate_table.c
+test_exchangedb_populate_table_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -ljansson \
+ -lgnunetjson \
+ -lgnunetutil \
+ $(XLIB)
+
+bench_db_postgres_SOURCES = \
+ bench_db.c
+bench_db_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -lgnunetpq \
+ -lgnunetutil \
+ $(XLIB)
EXTRA_test_exchangedb_postgres_DEPENDENCIES = \
libtaler_plugin_exchangedb_postgres.la