aboutsummaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-07-28 22:27:23 +0200
committerChristian Grothoff <christian@grothoff.org>2022-07-28 22:27:23 +0200
commitdc26b2db4cecbca155f5df2678f60aadf13c3bd4 (patch)
treeefd3d15d2ad2109ab17f8181e0af01a210ec0602 /src/exchangedb/Makefile.am
parent5f1d8fc4065e49c0cb0f1686824339bd5a3f7e15 (diff)
downloadexchange-dc26b2db4cecbca155f5df2678f60aadf13c3bd4.tar.xz
-ensure single transaction for exchange-0001.sql / shard-0001.sql
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index af2bfc0c6..01ce13dec 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -16,8 +16,10 @@ sqldir = $(prefix)/share/taler/sql/exchange/
sqlinputs = \
common-0001.sql \
+ exchange-0001.sql.in \
exchange-0001-part.sql \
- shard-0001-part.sql
+ shard-0001-part.sql \
+ shard-0001.sql.in
sql_DATA = \
benchmark-0001.sql \
@@ -25,7 +27,7 @@ sql_DATA = \
exchange-0001.sql \
drop.sql \
procedures.sql \
- shard-0001.sql
+ shard-0001.sql
BUILT_SOURCES = \
shard-0001.sql \
@@ -35,16 +37,16 @@ BUILT_SOURCES = \
CLEANFILES = \
shard-0001.sql \
- exchange-0001.sql
+ exchange-0001.sql
-exchange-0001.sql: common-0001.sql exchange-0001-part.sql
+exchange-0001.sql: common-0001.sql exchange-0001-part.sql exchange-0001.sql.in
chmod +w $@ || true
- cat common-0001.sql exchange-0001-part.sql >$@
+ gcc -E -P -undef - < exchange-0001.sql.in 2>/dev/null | sed -e "s/--.*//" | awk 'NF' - >$@
chmod ugo-w $@
-shard-0001.sql: common-0001.sql shard-0001-part.sql
+shard-0001.sql: common-0001.sql shard-0001-part.sql exchange-0001.sql.in
chmod +w $@ || true
- cat common-0001.sql shard-0001-part.sql >$@
+ gcc -E -P -undef - < shard-0001.sql.in 2>/dev/null | sed -e "s/--.*//" | awk 'NF' - >$@
chmod ugo-w $@
EXTRA_DIST = \