aboutsummaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorJoseph <Joseph.xu@efrei.net>2023-01-11 05:54:49 -0500
committerJoseph <Joseph.xu@efrei.net>2023-01-11 05:55:14 -0500
commit5de648b0f6f8efba2665dd05cf3b4f45a1ac164b (patch)
treeba249130b135d170bd4f2ee6e827e26cede86ad0 /src/exchangedb/Makefile.am
parent23626c02c7cbb980c0aa46ecc9fe3b55bbb55aa4 (diff)
downloadexchange-5de648b0f6f8efba2665dd05cf3b4f45a1ac164b.tar.xz
new functions for inserting into link_data ready_deposit refunds
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am55
1 files changed, 53 insertions, 2 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index ddb899a0a..40607af68 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -296,7 +296,9 @@ check_PROGRAMS = \
perf-exchangedb-reserves-in-insert-postgres\
test-exchangedb-by-j-postgres\
test-exchangedb-batch-reserves-in-insert-postgres\
- test-exchangedb-populate-table-postgres
+ test-exchangedb-populate-table-postgres\
+ test-exchangedb-populate-link-data-postgres\
+ test-exchangedb-populate-ready-deposit-postgres
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
TESTS = \
@@ -304,7 +306,9 @@ TESTS = \
test-exchangedb-by-j-postgres\
perf-exchangedb-reserves-in-insert-postgres\
test-exchangedb-batch-reserves-in-insert-postgres\
- test-exchangedb-populate-table-postgres
+ test-exchangedb-populate-table-postgres\
+ test-exchangedb-populate-link-data-postgres\
+ test-exchangedb-populate-ready-deposit-postgres
test_exchangedb_postgres_SOURCES = \
test_exchangedb.c
test_exchangedb_postgres_LDADD = \
@@ -375,6 +379,53 @@ test_exchangedb_populate_table_postgres_LDADD = \
-ljansson \
-lgnunetjson \
-lgnunetutil \
+ -lm \
+ $(XLIB)
+
+bench_db_postgres_SOURCES = \
+ bench_db.c
+bench_db_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -lgnunetpq \
+ -lgnunetutil \
+ $(XLIB)
+
+test_exchangedb_populate_link_data_postgres_SOURCES = \
+ test_exchangedb_populate_link_data.c
+test_exchangedb_populate_link_data_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -ljansson \
+ -lgnunetjson \
+ -lgnunetutil \
+ -lm \
+ $(XLIB)
+
+bench_db_postgres_SOURCES = \
+ bench_db.c
+bench_db_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -lgnunetpq \
+ -lgnunetutil \
+ $(XLIB)
+
+test_exchangedb_populate_ready_deposit_postgres_SOURCES = \
+ test_exchangedb_populate_ready_deposit.c
+test_exchangedb_populate_ready_deposit_postgres_LDADD = \
+ libtalerexchangedb.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ -ljansson \
+ -lgnunetjson \
+ -lgnunetutil \
+ -lm \
$(XLIB)
EXTRA_test_exchangedb_postgres_DEPENDENCIES = \