aboutsummaryrefslogtreecommitdiff
path: root/src/exchange-tools/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2021-12-08 15:54:48 +0100
committerFlorian Dold <florian@dold.me>2021-12-08 15:54:48 +0100
commita00cebcced1bdee1da998177c06986c1886eb55a (patch)
tree5bfa6f2e51f100686e419469bd149c925660fb1e /src/exchange-tools/Makefile.am
parent9d3f7d3a56712d6a963e8a4775a8f9757740d648 (diff)
downloadexchange-a00cebcced1bdee1da998177c06986c1886eb55a.tar.xz
put crypto worker in exchange-tools, re-enable build
Diffstat (limited to 'src/exchange-tools/Makefile.am')
-rw-r--r--src/exchange-tools/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/src/exchange-tools/Makefile.am b/src/exchange-tools/Makefile.am
index 82f4cbeb9..846ea6132 100644
--- a/src/exchange-tools/Makefile.am
+++ b/src/exchange-tools/Makefile.am
@@ -15,7 +15,8 @@ endif
bin_PROGRAMS = \
taler-auditor-offline \
taler-exchange-offline \
- taler-exchange-dbinit
+ taler-exchange-dbinit \
+ taler-crypto-worker
taler_exchange_offline_SOURCES = \
taler-exchange-offline.c
@@ -59,6 +60,20 @@ taler_exchange_dbinit_CPPFLAGS = \
-I$(top_srcdir)/src/pq/ \
$(POSTGRESQL_CPPFLAGS)
+taler_crypto_worker_SOURCES = \
+ taler-crypto-worker.c
+taler_crypto_worker_LDADD = \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ -lgnunetutil \
+ -lgnunetjson \
+ -ljansson \
+ -lpthread \
+ $(LIBGCRYPT_LIBS) \
+ $(XLIB)
+
+
+
# Testcases