aboutsummaryrefslogtreecommitdiff
path: root/src/auditordb/pg_template.sh
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-11-02 12:17:05 +0100
committerChristian Grothoff <christian@grothoff.org>2022-11-02 12:17:05 +0100
commit821c87ccbddbb7b0d0896f350de0a671f210ae40 (patch)
tree39b3f7c8294ea60c436730d9d2bcaa5ec97eeab0 /src/auditordb/pg_template.sh
parent1d483e2e17efc9fce5e2b3c27fe533e386178e3d (diff)
downloadexchange-821c87ccbddbb7b0d0896f350de0a671f210ae40.tar.xz
clean up exchange DB logic a bit, add missing function
Diffstat (limited to 'src/auditordb/pg_template.sh')
-rwxr-xr-xsrc/auditordb/pg_template.sh21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/auditordb/pg_template.sh b/src/auditordb/pg_template.sh
new file mode 100755
index 000000000..73bd7e989
--- /dev/null
+++ b/src/auditordb/pg_template.sh
@@ -0,0 +1,21 @@
+#!/bin/sh
+# This file is in the public domain.
+#
+# Instantiates pg_template for a particular function.
+
+for n in $*
+do
+ NCAPS=`echo $n | tr a-z A-Z`
+ if test ! -e pg_$n.c
+ then
+ cat pg_template.c | sed -e s/template/$n/g -e s/TEMPLATE/$NCAPS/g > pg_$n.c
+ cat pg_template.h | sed -e s/template/$n/g -e s/TEMPLATE/$NCAPS/g > pg_$n.h
+ echo " plugin->$n\n = &TEH_PG_$n;" >> tmpl.c
+ echo "#include \"pg_$n.h\"" >> tmpl.inc
+ echo " pg_$n.h pg_$n.c \\" >> tmpl.am
+ fi
+done
+
+echo "Add lines from tmpl.am to Makefile.am"
+echo "Add lines from tmpl.inc to plugin_exchangedb_postgres.c at the beginning"
+echo "Add lines from tmpl.c to plugin_exchangedb_postgres.c at the end"