aboutsummaryrefslogtreecommitdiff
path: root/src/auditordb/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-11-02 12:17:05 +0100
committerChristian Grothoff <christian@grothoff.org>2022-11-02 12:17:05 +0100
commit821c87ccbddbb7b0d0896f350de0a671f210ae40 (patch)
tree39b3f7c8294ea60c436730d9d2bcaa5ec97eeab0 /src/auditordb/Makefile.am
parent1d483e2e17efc9fce5e2b3c27fe533e386178e3d (diff)
downloadexchange-821c87ccbddbb7b0d0896f350de0a671f210ae40.tar.xz
clean up exchange DB logic a bit, add missing function
Diffstat (limited to 'src/auditordb/Makefile.am')
-rw-r--r--src/auditordb/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/auditordb/Makefile.am b/src/auditordb/Makefile.am
index 7ca168d01..d00c4fb23 100644
--- a/src/auditordb/Makefile.am
+++ b/src/auditordb/Makefile.am
@@ -23,7 +23,9 @@ EXTRA_DIST = \
auditordb-postgres.conf \
test-auditor-db-postgres.conf \
$(sql_DATA) \
- 9999.sql
+ 9999.sql \
+ pg_template.h pg_template.c \
+ pg_template.sh
plugindir = $(libdir)/taler
@@ -83,6 +85,14 @@ libtaler_plugin_auditordb_postgres_la_SOURCES = \
pg_delete_exchange.h pg_delete_exchange.c \
pg_insert_exchange_signkey.h pg_insert_exchange_signkey.c \
pg_insert_deposit_confirmation.h pg_insert_deposit_confirmation.c \
+ pg_get_purse_info.h pg_get_purse_info.c \
+ pg_delete_purse_info.h pg_delete_purse_info.c \
+ pg_update_purse_info.h pg_update_purse_info.c \
+ pg_insert_purse_info.h pg_insert_purse_info.c \
+ pg_get_purse_summary.h pg_get_purse_summary.c \
+ pg_select_purse_expired.h pg_select_purse_expired.c \
+ pg_insert_purse_summary.h pg_insert_purse_summary.c \
+ pg_update_purse_summary.h pg_update_purse_summary.c \
pg_get_deposit_confirmations.h pg_get_deposit_confirmations.c
libtaler_plugin_auditordb_postgres_la_LIBADD = \
$(LTLIBINTL)