aboutsummaryrefslogtreecommitdiff
path: root/src/auditordb/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2016-11-04 14:20:50 +0100
committerMarcello Stanisci <marcello.stanisci@inria.fr>2016-11-04 14:20:50 +0100
commit7177c5c015102e3927976119c989a6a75e376bdc (patch)
tree3553f5a716a30efcd943eccc0d0965a50cebabb8 /src/auditordb/Makefile.am
parent1244bcf3a6329f8327e40b74e858da5890891130 (diff)
parentf113c1ebd6f98d4aa4c8c5eb6ab7e08b11c17a27 (diff)
downloadexchange-7177c5c015102e3927976119c989a6a75e376bdc.tar.xz
Merge branch 'master' of taler.net:exchange
Diffstat (limited to 'src/auditordb/Makefile.am')
-rw-r--r--src/auditordb/Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/src/auditordb/Makefile.am b/src/auditordb/Makefile.am
index e8ec40272..640f95f25 100644
--- a/src/auditordb/Makefile.am
+++ b/src/auditordb/Makefile.am
@@ -12,7 +12,8 @@ pkgcfg_DATA = \
auditordb-postgres.conf
EXTRA_DIST = \
- auditordb-postgres.conf
+ auditordb-postgres.conf \
+ test-auditor-db-postgres.conf
plugindir = $(libdir)/taler
@@ -49,5 +50,21 @@ libtalerauditordb_la_LDFLAGS = \
-no-undefined
-EXTRA_test_auditordb_postgres_DEPENDENCIES = \
- libtaler_plugin_auditordb_postgres.la
+#EXTRA_test_auditordb_postgres_DEPENDENCIES = \
+# libtaler_plugin_auditordb_postgres.la
+
+
+check_PROGRAMS = \
+ test-auditordb-postgres
+
+AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
+TESTS = \
+ test-auditordb-postgres
+
+test_auditordb_postgres_SOURCES = \
+ test_auditordb.c
+test_auditordb_postgres_LDADD = \
+ libtalerauditordb.la \
+ $(top_srcdir)/src/pq/libtalerpq.la \
+ $(top_srcdir)/src/util/libtalerutil.la \
+ -lgnunetutil