aboutsummaryrefslogtreecommitdiff
path: root/src/auditor/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2024-08-23 14:15:18 +0200
committerChristian Grothoff <christian@grothoff.org>2024-08-23 14:16:03 +0200
commit9c21e22da9e2f411cfc3d2c900f4aabe2e3a88f1 (patch)
tree0a5bea2d721f5af7597d7930bf7a4b1fa7f042b3 /src/auditor/Makefile.am
parenta70c64d085bddfae6ebc07ebd9ceb796fbf03e62 (diff)
split off taler-helper-auditor-transfer to reduce mixing up different things in helpers; also clean up its code
Diffstat (limited to 'src/auditor/Makefile.am')
-rw-r--r--src/auditor/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/auditor/Makefile.am b/src/auditor/Makefile.am
index 622794b78..1a78cb3a2 100644
--- a/src/auditor/Makefile.am
+++ b/src/auditor/Makefile.am
@@ -23,6 +23,7 @@ bin_PROGRAMS = \
taler-helper-auditor-deposits \
taler-helper-auditor-purses \
taler-helper-auditor-reserves \
+ taler-helper-auditor-transfer \
taler-helper-auditor-wire-credit \
taler-helper-auditor-wire-debit
@@ -141,7 +142,19 @@ taler_helper_auditor_reserves_LDADD = \
-lgnunetutil \
$(XLIB)
-
+taler_helper_auditor_transfer_SOURCES = \
+ taler-helper-auditor-transfer.c
+taler_helper_auditor_transfer_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ $(top_builddir)/src/auditordb/libtalerauditordb.la \
+ libauditorreport.la \
+ -ljansson \
+ -lgnunetjson \
+ -lgnunetutil \
+ $(XLIB)
taler_helper_auditor_wire_credit_SOURCES = \
taler-helper-auditor-wire-credit.c