aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-01-05 18:10:45 +0100
committerChristian Grothoff <christian@grothoff.org>2021-01-05 18:10:45 +0100
commit9e0194c1f2823b8588eed2d9a6e3dfd86788f968 (patch)
tree54636d39a11d8df25d5dac6026abd7d6aa976c03 /Makefile.am
parent876404736873969ea112a4f2fd1b725e2be7c9d6 (diff)
parent8c55968452b4c297660e2fa8fffa7e7df37908ba (diff)
Merge branch 'master' of git+ssh://git.taler.net/exchange
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d62e19a50..d2e8d8e05 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,19 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
-SUBDIRS = . contrib src doc
+if DOC_ONLY
+if ENABLE_DOC
+ SUBDIRS = . contrib doc
+else
+ SUBDIRS = . contrib
+endif
+else
+if ENABLE_DOC
+ SUBDIRS = . contrib src doc
+else
+ SUBDIRS = . contrib src
+endif
+endif
BUILT_SOURCES = src/include/taler_error_codes.h