aboutsummaryrefslogtreecommitdiff
path: root/system/watch-fs/watch-fs.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/watch-fs/watch-fs.SlackBuild')
-rw-r--r--system/watch-fs/watch-fs.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/system/watch-fs/watch-fs.SlackBuild b/system/watch-fs/watch-fs.SlackBuild
index 5af9b4ca9850f..a6c631f42559f 100644
--- a/system/watch-fs/watch-fs.SlackBuild
+++ b/system/watch-fs/watch-fs.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for watch-fs
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -22,6 +23,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220512 46and2: Added python3 support, shorten DOWNLOAD url, New maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=watch-fs
@@ -79,7 +82,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true