aboutsummaryrefslogtreecommitdiff
path: root/system/rfdump/rfdump.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/rfdump/rfdump.SlackBuild')
-rw-r--r--system/rfdump/rfdump.SlackBuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/system/rfdump/rfdump.SlackBuild b/system/rfdump/rfdump.SlackBuild
index 06f7d783bcaf0..da9b558406053 100644
--- a/system/rfdump/rfdump.SlackBuild
+++ b/system/rfdump/rfdump.SlackBuild
@@ -22,6 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220210 bkw: Modified by SlackBuilds.org, to fix the build on 15.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rfdump
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,14 +74,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220210 bkw: make the configure script actually use CFLAGS from
+# the env (patch comes from Debian).
+patch -p1 < $CWD/02_configure.in-preserve-CFLAGS.patch
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -fcommon" \
+LDFLAGS="-lexpat" \
./configure \
- LDFLAGS="-lexpat" \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
@@ -92,10 +94,7 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING INSTALL NEWS README TODO $PKG/usr/doc/$PRGNAM-$VERSION