aboutsummaryrefslogtreecommitdiff
path: root/system/powertop/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/powertop/Makefile.patch')
-rw-r--r--system/powertop/Makefile.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/system/powertop/Makefile.patch b/system/powertop/Makefile.patch
new file mode 100644
index 0000000000000..848963c71782c
--- /dev/null
+++ b/system/powertop/Makefile.patch
@@ -0,0 +1,23 @@
+--- Makefile~ 2007-06-17 10:59:11.000000000 -0500
++++ Makefile 2007-07-07 14:56:44.000000000 -0500
+@@ -1,8 +1,9 @@
+ BINDIR=/usr/bin
+ LOCALESDIR=/usr/share/locale
+-MANDIR=/usr/share/man/man1
++MANDIR=/usr/man/man1
+ WARNFLAGS=-Wall -W -Wshadow
+-CFLAGS?=-Os -g ${WARNFLAGS}
++CFLAGS?=-Os -g
++CFLAGS+=${WARNFLAGS}
+ CC?=gcc
+
+
+@@ -24,7 +25,7 @@
+ @(cd po/ && $(MAKE))
+
+ powertop.1.gz: powertop.1
+- gzip -c $< > $@
++ gzip -9 -c $< > $@
+
+ install: powertop powertop.1.gz
+ mkdir -p ${DESTDIR}${BINDIR}